What’s Vulnerable › Vulnerabilities
CVE-2025-21083: Insufficient Input Validation on Post Props
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-15 · updated 2026-06-17
- Weakness: CWE-1287
Description
Mattermost Mobile Apps versions <=2.22.0 fail to properly validate post props which allows a malicious authenticated user to cause a crash via a malicious post.
Affected products
- Mattermost Mobile: before 2.23.0 — fixed in 2.23.0
How to fix
Upgrade to a fixed version: Mattermost Mobile 2.23.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-21083 or the next vulnerability affects your stack