What’s Vulnerable › Vulnerabilities
CVE-2025-2109: WP Compress <= 6.30.15 - Unauthenticated Server-Side Request Forgery via init Function
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-918
Description
The WP Compress – Instant Performance & Speed Optimization plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 6.30.15 via the init() function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query information from internal services.
Affected products
- aresit WP Compress – Instant Performance & Speed Optimization: before 6.30.16 — fixed in 6.30.16
How to fix
Upgrade to a fixed version: aresit WP Compress – Instant Performance & Speed Optimization 6.30.16. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-compress-image-optimizer/tags/6.30.15/wp-compress-core.php#L994
- https://plugins.trac.wordpress.org/changeset/3254259/
- https://wordpress.org/plugins/wp-compress-image-optimizer/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/10b9d703-de9d-472a-bdfb-bc9a41bf375e?source=cve
Get alerted when CVE-2025-2109 or the next vulnerability affects your stack