What’s Vulnerable › Vulnerabilities
CVE-2025-2110: WP Compress <= 6.30.15 - Authenticated (Subscriber+) Missing Authorization via Multiple Functions
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-26 · updated 2026-06-17
- Weakness: CWE-862
Description
The WP Compress – Instant Performance & Speed Optimization plugin for WordPress is vulnerable to unauthorized access, modification, and loss of data due to missing capability checks on its on its AJAX functions in all versions up to, and including, 6.30.15. This makes it possible for authenticated attackers, with Subscriber-level access and above, to compromise the site in various ways depending on the specific function exploited - for example, by retrieving sensitive settings and configuration details, or by altering and deleting them, thereby disclosing sensitive information, disrupting the plugin’s functionality, and potentially impacting overall site performance.
Affected products
- aresit WP Compress – Instant Performance & Speed Optimization: before 6.30.16 — fixed in 6.30.16
How to fix
Upgrade to a fixed version: aresit WP Compress – Instant Performance & Speed Optimization 6.30.16. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-compress-image-optimizer/tags/6.30.15/classes/ajax.class.php
- https://plugins.trac.wordpress.org/changeset/3254259/
- https://wordpress.org/plugins/wp-compress-image-optimizer/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2bb4ead4-b2ad-42b4-92a0-fb7293f6df06?source=cve
Get alerted when CVE-2025-2110 or the next vulnerability affects your stack