What’s Vulnerable › Vulnerabilities
CVE-2025-21126: InDesign Desktop | Improper Input Validation (CWE-20)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-20
Description
InDesign Desktop versions ID20.0, ID19.5.1 and earlier are affected by an Improper Input Validation vulnerability that could result in an application denial-of-service condition. An attacker could exploit this vulnerability to cause the application to crash, resulting in a denial of service. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe InDesign Desktop: before 19.5.2; 20.0 — fixed in 19.5.2
How to fix
Upgrade to a fixed version: Adobe InDesign Desktop 19.5.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-21126 or the next vulnerability affects your stack