What’s Vulnerable › Vulnerabilities
CVE-2025-21128: Substance3D - Stager | Stack-based Buffer Overflow (CWE-121)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-121
Description
Substance3D - Stager versions 3.0.4 and earlier are affected by a Stack-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Substance3D - Stager: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: Adobe Substance3D - Stager 3.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-21128 or the next vulnerability affects your stack