What’s Vulnerable › Vulnerabilities
CVE-2025-21163: Illustrator | Stack-based Buffer Overflow (CWE-121)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-121
Description
Illustrator versions 29.1, 28.7.3 and earlier are affected by a Stack-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 28.0 before 28.7.4; from 29.0 before 29.2.1 — fixed in 28.7.4, 29.2.1
How to fix
Upgrade to a fixed version: Adobe Illustrator 28.7.4, 29.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-21163 or the next vulnerability affects your stack