What’s Vulnerable › Vulnerabilities
CVE-2025-21187: Microsoft Power Automate Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-94
Description
Microsoft Power Automate Remote Code Execution Vulnerability
Affected products
- Microsoft Power Automate for Desktop: from 2.46 before 2.46.184.25013; from 2.47 before 2.47.126.25010; from 2.48 before 2.48.164.25010; from 2.49 before 2.49.182.25010; from 2.50 before 2.50.139.25010; from 2.51 before 2.51.349.24355 — fixed in 2.46.184.25013, 2.47.126.25010, 2.48.164.25010, 2.49.182.25010, 2.50.139.25010, 2.51.349.24355
- Microsoft Power Automate for Desktop: from 1.0.0.0 before 2.52.62.25009 — fixed in 2.52.62.25009
How to fix
Upgrade to a fixed version: Microsoft Power Automate for Desktop 2.46.184.25013, 2.47.126.25010, 2.48.164.25010, 2.49.182.25010; Microsoft Power Automate for Desktop 2.52.62.25009. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-21187 or the next vulnerability affects your stack