What’s Vulnerable › Vulnerabilities
CVE-2025-21304: Microsoft DWM Core Library Elevation of Privilege Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-14 · updated 2026-06-17
- Weakness: CWE-416
Description
Microsoft DWM Core Library Elevation of Privilege Vulnerability
Affected products
- Microsoft Windows 10 1607: before 10.0.14393.7699 — fixed in 10.0.14393.7699
- Microsoft Windows 10: before 10.0.17763.6775 — fixed in 10.0.17763.6775
- Microsoft Windows 10: before 10.0.19044.5371 — fixed in 10.0.19044.5371
- Microsoft Windows 10: before 10.0.19045.5371 — fixed in 10.0.19045.5371
- Microsoft Windows Server 2016: before 10.0.14393.7699 — fixed in 10.0.14393.7699
- Microsoft Windows Server 2019: before 10.0.17763.6775 — fixed in 10.0.17763.6775
- Microsoft Windows 10 1607: from 10.0.14393.0 before 10.0.14393.7699 — fixed in 10.0.14393.7699
- Microsoft Windows 10: from 10.0.17763.0 before 10.0.17763.6775 — fixed in 10.0.17763.6775
- Microsoft Windows 10: from 10.0.19044.0 before 10.0.19044.5371 — fixed in 10.0.19044.5371
- Microsoft Windows 10: from 10.0.19045.0 before 10.0.19045.5371 — fixed in 10.0.19045.5371
- Microsoft Windows Server 2016: from 10.0.14393.0 before 10.0.14393.7699 — fixed in 10.0.14393.7699
- Microsoft Windows Server 2019: from 10.0.17763.0 before 10.0.17763.6775 — fixed in 10.0.17763.6775
How to fix
Upgrade to a fixed version: Microsoft Windows 10 1607 10.0.14393.7699; Microsoft Windows 10 10.0.17763.6775; Microsoft Windows 10 10.0.19044.5371; Microsoft Windows 10 10.0.19045.5371; Microsoft Windows Server 2016 10.0.14393.7699; Microsoft Windows Server 2019 10.0.17763.6775; Microsoft Windows 10 1607 10.0.14393.7699; Microsoft Windows 10 10.0.17763.6775; Microsoft Windows 10 10.0.19044.5371; Microsoft Windows 10 10.0.19045.5371; Microsoft Windows Server 2016 10.0.14393.7699; Microsoft Windows Server 2019 10.0.17763.6775. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-21304 or the next vulnerability affects your stack