What’s Vulnerable › Vulnerabilities
CVE-2025-21610: Trix allows Cross-site Scripting via `javascript:` url in a link
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.12 are vulnerable to cross-site scripting when pasting malicious code in the link field. An attacker could trick the user to copy&paste a malicious `javascript:` URL as a link that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.12 or later to receive a patch. In addition to upgrading, affected users can disallow browsers that don't support a Content Security Policy (CSP) as a workaround for this and other cross-site scripting vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed, and explicitly prohibit inline scripts using script-src-elem.
Affected products
- basecamp trix: before 2.1.12
References
- https://gist.github.com/th4s1s/3921fd9c3e324ad9a3e0d846166e3eb8
- https://github.com/basecamp/trix/commit/180c8d337f18e1569cea6ef29b4d03ffff5b5faa
- https://github.com/basecamp/trix/commit/c4f0d6f80654603932af6685694f694e96593b93
- https://github.com/basecamp/trix/security/advisories/GHSA-j386-3444-qgwg
Get alerted when CVE-2025-21610 or the next vulnerability affects your stack