What’s Vulnerable › Vulnerabilities
CVE-2025-21611: tgstation-server's role authorization incorrectly OR'd with user's enabled status
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-06 · updated 2026-06-17
- Weakness: CWE-285
Description
tgstation-server is a production scale tool for BYOND server management. Prior to 6.12.3, roles used to authorize API methods were incorrectly OR'd instead of AND'ed with the role used to determine if a user was enabled. This allows enabled users access to most, but not all, authorized actions regardless of their permissions. Notably, the WriteUsers right is unaffected so users may not use this bug to permanently elevate their account permissions. The fix is release in tgstation-server-v6.12.3.
Affected products
- tgstation-server: from 6.11.0 before 6.12.3 — fixed in 6.12.3
How to fix
Upgrade to a fixed version: tgstation-server 6.12.3. Check the vendor advisory for mitigations.
References
- https://github.com/tgstation/tgstation-server/commit/e7b1189620baaf03c2d23f6e164d07c7c7d87d57
- https://github.com/tgstation/tgstation-server/issues/2064
- https://github.com/tgstation/tgstation-server/security/advisories/GHSA-rf5r-q276-vrc4
Get alerted when CVE-2025-21611 or the next vulnerability affects your stack