What’s Vulnerable › Vulnerabilities
CVE-2025-21613: go-git has an Argument Injection via the URL field
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-06 · updated 2026-06-17
- Weakness: CWE-88
Description
go-git is a highly extensible git implementation library written in pure Go. An argument injection vulnerability was discovered in go-git versions prior to v5.13. Successful exploitation of this vulnerability could allow an attacker to set arbitrary values to git-upload-pack flags. This only happens when the file transport protocol is being used, as that is the only protocol that shells out to git binaries. This vulnerability is fixed in 5.13.0.
Affected products
- go-git: before 5.13.0 — fixed in 5.13.0
How to fix
Upgrade to a fixed version: go-git 5.13.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-21613 or the next vulnerability affects your stack