What’s Vulnerable › Vulnerabilities
CVE-2025-21614: go-git clients vulnerable to DoS via maliciously crafted Git server replies
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-06 · updated 2026-06-17
- Weakness: CWE-400
Description
go-git is a highly extensible git implementation library written in pure Go. A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.13. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in go-git clients. Users running versions of go-git from v4 and above are recommended to upgrade to v5.13 in order to mitigate this vulnerability.
Affected products
- go-git: before 5.13.0 — fixed in 5.13.0
How to fix
Upgrade to a fixed version: go-git 5.13.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-21614 or the next vulnerability affects your stack