What’s Vulnerable › Vulnerabilities
CVE-2025-2162: MapPress Maps for WordPress < 2.94.10 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The MapPress Maps for WordPress plugin before 2.94.10 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- MapPress Maps for WordPress: before 2.94.10 — fixed in 2.94.10
How to fix
Upgrade to a fixed version: MapPress Maps for WordPress 2.94.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/06063788-7ab8-49cc-9911-1d9926fcf99d/
- https://wpscan.com/vulnerability/06063788-7ab8-49cc-9911-1d9926fcf99d/
Get alerted when CVE-2025-2162 or the next vulnerability affects your stack