What’s Vulnerable › Vulnerabilities
CVE-2025-21621: GeoServer Reflected Cross-Site Scripting (XSS) vulnerability in WMS GetFeatureInfo HTML format
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-79
Description
GeoServer is an open source server that allows users to share and edit geospatial data. Prior to version 2.25.0, a reflected cross-site scripting (XSS) vulnerability exists in the WMS GetFeatureInfo HTML output format that enables a remote attacker to execute arbitrary JavaScript code in a victim's browser through specially crafted SLD_BODY parameters. This issue has been patched in version 2.25.0.
Affected products
- geoserver: before 2.25.0 — fixed in 2.25.0
How to fix
Upgrade to a fixed version: geoserver 2.25.0. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/commit/dc9ff1c726dd73c884437a123b4ad72b19383c7d
- https://github.com/geoserver/geoserver/pull/7406
- https://github.com/geoserver/geoserver/security/advisories/GHSA-w66h-j855-qr72
- https://osgeo-org.atlassian.net/browse/GEOS-11297
Get alerted when CVE-2025-21621 or the next vulnerability affects your stack