What’s Vulnerable › Vulnerabilities
CVE-2025-21636: sctp: sysctl: plpmtud_probe_interval: avoid using current->nsproxy
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-19 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: sctp: sysctl: plpmtud_probe_interval: avoid using current->nsproxy As mentioned in a previous commit of this series, using the 'net' structure via 'current' is not recommended for different reasons: - Inconsistency: getting info from the reader's/writer's netns vs only from the opener's netns. - current->nsproxy can be NULL in some cases, resulting in an 'Oops' (null-ptr-deref), e.g. when the current task is exiting, as spotted by syzbot [1] using acct(2). The 'net' structure can be obtained from the table->data using container_of(). Note that table->data could also be used directly, as this is the only member needed from the 'net' structure, but that would increase the size of this fix, to use '*data' everywhere 'net->sctp.probe_interval' is used.
Affected products
- Linux kernel: from 5.14 before 5.15.177; from 5.16 before 6.1.125; from 6.2 before 6.6.72; from 6.7 before 6.12.10; 6.13-rc1, 6.13-rc2, 6.13-rc3, 6.13-rc4, 6.13-rc5, 6.13-rc6 — fixed in 5.15.177, 6.1.125, 6.12.10, 6.6.72
How to fix
Upgrade to a fixed version: Linux kernel 5.15.177, 6.1.125, 6.12.10, 6.6.72. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1dc5da6c4178f3e4b95c631418f72de9f86c0449
- https://git.kernel.org/stable/c/284a221f8fa503628432c7bb5108277c688c6ffa
- https://git.kernel.org/stable/c/44ee8635922b6eb940faddb961a8347c6857d722
- https://git.kernel.org/stable/c/6259d2484d0ceff42245d1f09cc8cb6ee72d847a
- https://git.kernel.org/stable/c/bcf8c60074e81ed2ac2d35130917175a3949c917
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
Get alerted when CVE-2025-21636 or the next vulnerability affects your stack