What’s Vulnerable › Vulnerabilities
CVE-2025-21648: netfilter: conntrack: clamp maximum hashtable size to INT_MAX
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-19 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: netfilter: conntrack: clamp maximum hashtable size to INT_MAX Use INT_MAX as maximum size for the conntrack hashtable. Otherwise, it is possible to hit WARN_ON_ONCE in __kvmalloc_node_noprof() when resizing hashtable because __GFP_NOWARN is unset. See: 0708a0afe291 ("mm: Consider __GFP_NOWARN flag for oversized kvmalloc() calls") Note: hashtable resize is only possible from init_netns.
Affected products
- Linux kernel: from 4.7.1 before 5.10.234; from 5.11 before 5.15.177; from 5.16 before 6.1.125; from 6.2 before 6.6.72; from 6.7 before 6.12.10; 4.7, 6.13-rc1, 6.13-rc2, 6.13-rc3, 6.13-rc4, 6.13-rc5 (+1) — fixed in 5.10.234, 5.15.177, 6.1.125, 6.12.10, 6.6.72
How to fix
Upgrade to a fixed version: Linux kernel 5.10.234, 5.15.177, 6.1.125, 6.12.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5552b4fd44be3393b930434a7845d8d95a2a3c33
- https://git.kernel.org/stable/c/a965f7f0ea3ae61b9165bed619d5d6da02c75f80
- https://git.kernel.org/stable/c/b1b2353d768f1b80cd7fe045a70adee576b9b338
- https://git.kernel.org/stable/c/b541ba7d1f5a5b7b3e2e22dc9e40e18a7d6dbc13
- https://git.kernel.org/stable/c/d5807dd1328bbc86e059c5de80d1bbee9d58ca3d
- https://git.kernel.org/stable/c/f559357d035877b9d0dcd273e0ff83e18e1d46aa
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-265688.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2025-21648 or the next vulnerability affects your stack