What’s Vulnerable › Vulnerabilities
CVE-2025-21659: netdev: prevent accessing NAPI instances from another namespace
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-21 · updated 2026-07-30
Description
In the Linux kernel, the following vulnerability has been resolved: netdev: prevent accessing NAPI instances from another namespace The NAPI IDs were not fully exposed to user space prior to the netlink API, so they were never namespaced. The netlink API must ensure that at the very least NAPI instance belongs to the same netns as the owner of the genl sock. napi_by_id() can become static now, but it needs to move because of dev_get_by_napi_id().
Affected products
- Linux kernel: from 6.8 before 6.12.10; 6.13-rc1, 6.13-rc2, 6.13-rc3, 6.13-rc4, 6.13-rc5, 6.13-rc6 — fixed in 6.12.10
How to fix
Upgrade to a fixed version: Linux kernel 6.12.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/b683ba0df11ff563cc237eb1b74d6adfa77226bf
- https://git.kernel.org/stable/c/d1cacd74776895f6435941f86a1130e58f6dd226
Get alerted when CVE-2025-21659 or the next vulnerability affects your stack