What’s Vulnerable › Vulnerabilities
CVE-2025-21690: scsi: storvsc: Ratelimit warning logs to prevent VM denial of service
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-10 · updated 2026-06-17
- Weakness: CWE-770
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: storvsc: Ratelimit warning logs to prevent VM denial of service If there's a persistent error in the hypervisor, the SCSI warning for failed I/O can flood the kernel log and max out CPU utilization, preventing troubleshooting from the VM side. Ratelimit the warning so it doesn't DoS the VM.
Affected products
- Linux kernel: before 5.15.178; from 5.16 before 6.1.128; from 6.2 before 6.6.75; from 6.7 before 6.12.12; 6.13, 6.13-rc1, 6.13-rc2, 6.13-rc3, 6.13-rc4, 6.13-rc5 (+2) — fixed in 5.15.178, 6.1.128, 6.12.12, 6.6.75
How to fix
Upgrade to a fixed version: Linux kernel 5.15.178, 6.1.128, 6.12.12, 6.6.75. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/01d1ebdab9ccb73c952e1666a8a80abd194dbc55
- https://git.kernel.org/stable/c/088bde862f8d3d0fc52e40e66a0484a246837087
- https://git.kernel.org/stable/c/182a4b7c731e95c08cb47f14b87a272b6ab2b2da
- https://git.kernel.org/stable/c/81d4dd05c412ba04f9f6b85b718e6da833be290c
- https://git.kernel.org/stable/c/d0f0af1bafef33b3e2aa8c3a4ef44db48df9b0ea
- https://git.kernel.org/stable/c/d2138eab8cde61e0e6f62d0713e45202e8457d6d
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
Get alerted when CVE-2025-21690 or the next vulnerability affects your stack