What’s Vulnerable › Vulnerabilities
CVE-2025-21735: NFC: nci: Add bounds checking in nci_hci_create_pipe()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-10-15
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: NFC: nci: Add bounds checking in nci_hci_create_pipe() The "pipe" variable is a u8 which comes from the network. If it's more than 127, then it results in memory corruption in the caller, nci_hci_connect_gate().
Affected products
- Linux kernel: from 4.4 before 6.1.129; from 6.2 before 6.6.78; from 6.7 before 6.12.14; from 6.13 before 6.13.3 — fixed in 6.1.129, 6.12.14, 6.13.3, 6.6.78
How to fix
Upgrade to a fixed version: Linux kernel 6.1.129, 6.12.14, 6.13.3, 6.6.78. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/10b3f947b609713e04022101f492d288a014ddfa
- https://git.kernel.org/stable/c/110b43ef05342d5a11284cc8b21582b698b4ef1c
- https://git.kernel.org/stable/c/172cdfc3a5ea20289c58fb73dadc6fd4a8784a4e
- https://git.kernel.org/stable/c/2ae4bade5a64d126bd18eb66bd419005c5550218
- https://git.kernel.org/stable/c/59c7ed20217c0939862fbf8145bc49d5b3a13f4f
- https://git.kernel.org/stable/c/674e17c5933779a8bf5c15d596fdfcb5ccdebbc2
- https://git.kernel.org/stable/c/bd249109d266f1d52548c46634a15b71656e0d44
- https://git.kernel.org/stable/c/d5a461c315e5ff92657f84d8ba50caa5abf5c22a
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://cert-portal.siemens.com/productcert/html/ssa-265688.html
- https://cert-portal.siemens.com/productcert/html/ssa-784472.html
Get alerted when CVE-2025-21735 or the next vulnerability affects your stack