What’s Vulnerable › Vulnerabilities
CVE-2025-2174: libzvbi conv.c vbi_strndup_iconv_ucs2 integer overflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-189
Description
A vulnerability was found in libzvbi up to 0.2.43. It has been declared as problematic. Affected by this vulnerability is the function vbi_strndup_iconv_ucs2 of the file src/conv.c. The manipulation of the argument src_length leads to integer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is named ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.
Affected products
- libzvbi: before 0.2.44 — fixed in 0.2.44
How to fix
Upgrade to a fixed version: libzvbi 0.2.44. Check the vendor advisory for mitigations.
References
- https://github.com/zapping-vbi/zvbi/commit/ca1672134b3e2962cd392212c73f44f8f4cb489f
- https://github.com/zapping-vbi/zvbi/releases/tag/v0.2.44
- https://github.com/zapping-vbi/zvbi/security/advisories/GHSA-g7cg-7gw9-v8cf
- https://vuldb.com/?ctiid.299203
- https://vuldb.com/?id.299203
- https://vuldb.com/?submit.512800
Get alerted when CVE-2025-2174 or the next vulnerability affects your stack