What’s Vulnerable › Vulnerabilities
CVE-2025-21743: usbnet: ipheth: fix possible overflow in DPE length check
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: usbnet: ipheth: fix possible overflow in DPE length check Originally, it was possible for the DPE length check to overflow if wDatagramIndex + wDatagramLength > U16_MAX. This could lead to an OoB read. Move the wDatagramIndex term to the other side of the inequality. An existing condition ensures that wDatagramIndex < urb->actual_length.
Affected products
- Linux kernel: from 6.5 before 6.6.78; from 6.7 before 6.12.14; from 6.13 before 6.13.3 — fixed in 6.12.14, 6.13.3, 6.6.78
How to fix
Upgrade to a fixed version: Linux kernel 6.12.14, 6.13.3, 6.6.78. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/18bf6f5cce3172cb303c3f0551aa9443d5ed74f8
- https://git.kernel.org/stable/c/c219427ed296f94bb4b91d08626776dc7719ee27
- https://git.kernel.org/stable/c/d677e7dd59ad6837496f5a02d8e5d39824278dfd
- https://git.kernel.org/stable/c/d824a964185910e317287f034c0a439c08b4fe49
Get alerted when CVE-2025-21743 or the next vulnerability affects your stack