What’s Vulnerable › Vulnerabilities
CVE-2025-21748: ksmbd: fix integer overflows on 32 bit systems
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-07-30
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix integer overflows on 32 bit systems On 32bit systems the addition operations in ipc_msg_alloc() can potentially overflow leading to memory corruption. Add bounds checking using KSMBD_IPC_MAX_PAYLOAD to avoid overflow.
Affected products
- Linux kernel: from 5.15 before 6.1.129; from 6.2 before 6.6.78; from 6.7 before 6.12.14; from 6.13 before 6.13.3 — fixed in 6.1.129, 6.12.14, 6.13.3, 6.6.78
How to fix
Upgrade to a fixed version: Linux kernel 6.1.129, 6.12.14, 6.13.3, 6.6.78. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/760568c1f62ea874e8fb492f9cfa4f47b4b8391e
- https://git.kernel.org/stable/c/82f59d64e6297f270311b16b5dcf65be406d1ea3
- https://git.kernel.org/stable/c/aab98e2dbd648510f8f51b83fbf4721206ccae45
- https://git.kernel.org/stable/c/b4b902737746c490258de5cb55cab39e79927a67
- https://git.kernel.org/stable/c/ecb9947fa7c99a77b04d43404c6988a0d326e4a0
- https://git.kernel.org/stable/c/f3b9fb2764591d792d160f375851013665a9e820
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
Get alerted when CVE-2025-21748 or the next vulnerability affects your stack