What’s Vulnerable › Vulnerabilities
CVE-2025-2175: libzvbi _vbi_strndup_iconv integer overflow
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-189
Description
A vulnerability was found in libzvbi up to 0.2.43. It has been rated as problematic. Affected by this issue is the function _vbi_strndup_iconv. The manipulation leads to integer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.
Affected products
- libzvbi: before 0.2.44 — fixed in 0.2.44
How to fix
Upgrade to a fixed version: libzvbi 0.2.44. Check the vendor advisory for mitigations.
References
- https://github.com/zapping-vbi/zvbi/releases/tag/v0.2.44
- https://github.com/zapping-vbi/zvbi/security/advisories/GHSA-g7cg-7gw9-v8cf
- https://vuldb.com/?ctiid.299204
- https://vuldb.com/?id.299204
- https://vuldb.com/?submit.512801
Get alerted when CVE-2025-2175 or the next vulnerability affects your stack