What’s Vulnerable › Vulnerabilities
CVE-2025-21764: ndisc: use RCU protection in ndisc_alloc_skb()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-10-15
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: ndisc: use RCU protection in ndisc_alloc_skb() ndisc_alloc_skb() can be called without RTNL or RCU being held. Add RCU protection to avoid possible UAF.
Affected products
- Linux kernel: from 3.9 before 5.4.291; from 5.5 before 5.10.235; from 5.11 before 5.15.179; from 5.16 before 6.1.129; from 6.2 before 6.6.79; from 6.7 before 6.12.16 — fixed in 5.10.235, 5.15.179, 5.4.291, 6.1.129, 6.12.16, 6.13.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.235, 5.15.179, 5.4.291, 6.1.129. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3c2d705f5adf5d860aaef90cb4211c0fde2ba66d
- https://git.kernel.org/stable/c/628e6d18930bbd21f2d4562228afe27694f66da9
- https://git.kernel.org/stable/c/96fc896d0e5b37c12808df797397fb16f3080879
- https://git.kernel.org/stable/c/9e0ec817eb41a55327a46cd3ce331a9868d60304
- https://git.kernel.org/stable/c/b870256dd2a5648d5ed2f22316b3ac29a7e5ed63
- https://git.kernel.org/stable/c/bbec88e4108e8d6fb468d3817fa652140a44ff28
- https://git.kernel.org/stable/c/c30893ef3d9cde8e7e8e4fd06b53d2c935bbccb1
- https://git.kernel.org/stable/c/cd1065f92eb7ff21b9ba5308a86f33d1670bf926
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-265688.html
Get alerted when CVE-2025-21764 or the next vulnerability affects your stack