What’s Vulnerable › Vulnerabilities
CVE-2025-21765: ipv6: use RCU protection in ip6_default_advmss()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: ipv6: use RCU protection in ip6_default_advmss() ip6_default_advmss() needs rcu protection to make sure the net structure it reads does not disappear.
Affected products
- Linux kernel: from 2.6.26 before 5.4.291; from 5.5 before 5.10.235; from 5.11 before 5.15.179; from 5.16 before 6.1.129; from 6.2 before 6.6.79; from 6.7 before 6.12.16 — fixed in 5.10.235, 5.15.179, 5.4.291, 6.1.129, 6.12.16, 6.13.4
How to fix
Upgrade to a fixed version: Linux kernel 5.10.235, 5.15.179, 5.4.291, 6.1.129. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/28de355b63ad42309ed5a03ee7c436c90512265b
- https://git.kernel.org/stable/c/3c8ffcd248da34fc41e52a46e51505900115fc2a
- https://git.kernel.org/stable/c/4176a68b0db8fc74ac14fcd00ba8231371051dc2
- https://git.kernel.org/stable/c/550ed693f47370502a71b85382e7f9e6417300b8
- https://git.kernel.org/stable/c/713a40c892f40300d63691d9f85b2a23b48fe1e8
- https://git.kernel.org/stable/c/78ad057472d8c76e0602402269222f9f9c698790
- https://git.kernel.org/stable/c/84212387caadb211cd9dadd6fd5563bd37dc1f5e
- https://git.kernel.org/stable/c/d02f30d220ef9511568a48dba8a9004c65f8d904
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
Get alerted when CVE-2025-21765 or the next vulnerability affects your stack