What’s Vulnerable › Vulnerabilities
CVE-2025-21766: ipv4: use RCU protection in __ip_rt_update_pmtu()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: ipv4: use RCU protection in __ip_rt_update_pmtu() __ip_rt_update_pmtu() must use RCU protection to make sure the net structure it reads does not disappear.
Affected products
- Linux kernel: from 4.14.200 before 4.15; from 4.19.148 before 4.20; from 5.4.68 before 5.5; from 5.8.12 before 5.9; from 5.9.1 before 5.15.179; from 5.16 before 6.1.129 — fixed in 4.15, 4.20, 5.15.179, 5.5, 5.9, 6.1.129
How to fix
Upgrade to a fixed version: Linux kernel 4.15, 4.20, 5.15.179, 5.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/139512191bd06f1b496117c76372b2ce372c9a41
- https://git.kernel.org/stable/c/4583748b65dee4d61bd50a2214715b4237bc152a
- https://git.kernel.org/stable/c/9b1766d1ff5fe496aabe9fc5f4e34e53f35c11c4
- https://git.kernel.org/stable/c/a39f61d212d822b3062d7f70fa0588e50e55664e
- https://git.kernel.org/stable/c/ce3c6165fce0f06305c806696882a3ad4b90e33f
- https://git.kernel.org/stable/c/ea07480b23225942208f1b754fea1e7ec486d37e
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
- https://cert-portal.siemens.com/productcert/html/ssa-784472.html
Get alerted when CVE-2025-21766 or the next vulnerability affects your stack