What’s Vulnerable › Vulnerabilities
CVE-2025-21780: drm/amdgpu: avoid buffer overflow attach in smu_sys_set_pp_table()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-10-15
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amdgpu: avoid buffer overflow attach in smu_sys_set_pp_table() It malicious user provides a small pptable through sysfs and then a bigger pptable, it may cause buffer overflow attack in function smu_sys_set_pp_table().
Affected products
- Linux kernel: before 6.1.129; from 6.2 before 6.6.79; from 6.7 before 6.12.16; from 6.13 before 6.13.4; 6.14-rc1, 6.14-rc2 — fixed in 6.1.129, 6.12.16, 6.13.4, 6.6.79
How to fix
Upgrade to a fixed version: Linux kernel 6.1.129, 6.12.16, 6.13.4, 6.6.79. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1abb2648698bf10783d2236a6b4a7ca5e8021699
- https://git.kernel.org/stable/c/231075c5a8ea54f34b7c4794687baa980814e6de
- https://git.kernel.org/stable/c/2498d2db1d35e88a2060ea191ae75dce853dd084
- https://git.kernel.org/stable/c/3484ea33157bc7334f57e64826ec5a4bf992151a
- https://git.kernel.org/stable/c/e43a8b9c4d700ffec819c5043a48769b3e7d9cab
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2025-21780 or the next vulnerability affects your stack