What’s Vulnerable › Vulnerabilities
CVE-2025-21783: gpiolib: Fix crash on error in gpiochip_get_ngpios()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: gpiolib: Fix crash on error in gpiochip_get_ngpios() The gpiochip_get_ngpios() uses chip_*() macros to print messages. However these macros rely on gpiodev to be initialised and set, which is not the case when called via bgpio_init(). In such a case the printing messages will crash on NULL pointer dereference. Replace chip_*() macros by the respective dev_*() ones to avoid such crash.
Affected products
- Linux kernel: from 6.6 before 6.6.79; from 6.7 before 6.12.16; from 6.13 before 6.13.4; 6.14-rc1, 6.14-rc2 — fixed in 6.12.16, 6.13.4, 6.6.79
How to fix
Upgrade to a fixed version: Linux kernel 6.12.16, 6.13.4, 6.6.79. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/189fb76215e479c10731baabb50f1a352d2078f5
- https://git.kernel.org/stable/c/4d9b2b62e1136d10f661ec4c0c268140b6f74f4f
- https://git.kernel.org/stable/c/7b4aebeecbbd5b5fe73e35fad3f62ed21aa7ef44
- https://git.kernel.org/stable/c/a7052afa9eae2239e25943baa8817a6a56e8aa68
Get alerted when CVE-2025-21783 or the next vulnerability affects your stack