What’s Vulnerable › Vulnerabilities
CVE-2025-21785: arm64: cacheinfo: Avoid out-of-bounds write to cacheinfo array
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-10-15
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: arm64: cacheinfo: Avoid out-of-bounds write to cacheinfo array The loop that detects/populates cache information already has a bounds check on the array size but does not account for cache levels with separate data/instructions cache. Fix this by incrementing the index for any populated leaf (instead of any populated level).
Affected products
- Linux kernel: from 4.0 before 6.1.129; from 6.2 before 6.6.79; from 6.7 before 6.12.16; from 6.13 before 6.13.4; 6.14-rc1, 6.14-rc2 — fixed in 6.1.129, 6.12.16, 6.13.4, 6.6.79
How to fix
Upgrade to a fixed version: Linux kernel 6.1.129, 6.12.16, 6.13.4, 6.6.79. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4371ac7b494e933fffee2bd6265d18d73c4f05aa
- https://git.kernel.org/stable/c/4ff25f0b18d1d0174c105e4620428bcdc1213860
- https://git.kernel.org/stable/c/67b99a2b5811df4294c2ad50f9bff3b6a08bd618
- https://git.kernel.org/stable/c/715eb1af64779e1b1aa0a7b2ffb81414d9f708e5
- https://git.kernel.org/stable/c/875d742cf5327c93cba1f11e12b08d3cce7a88d2
- https://git.kernel.org/stable/c/88a3e6afaf002250220793df99404977d343db14
- https://git.kernel.org/stable/c/ab90894f33c15b14c1cee6959ab6c8dcb09127f8
- https://git.kernel.org/stable/c/e4fde33107351ec33f1a64188612fbc6ca659284
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
Get alerted when CVE-2025-21785 or the next vulnerability affects your stack