What’s Vulnerable › Vulnerabilities
CVE-2025-21791: vrf: use RCU protection in l3mdev_l3_out()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-10-15
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: vrf: use RCU protection in l3mdev_l3_out() l3mdev_l3_out() can be called without RCU being held: raw_sendmsg() ip_push_pending_frames() ip_send_skb() ip_local_out() __ip_local_out() l3mdev_ip_out() Add rcu_read_lock() / rcu_read_unlock() pair to avoid a potential UAF.
Affected products
- Linux kernel: from 4.9 before 6.1.129; from 6.2 before 6.6.79; from 6.7 before 6.12.16; from 6.13 before 6.13.4; 6.14-rc1, 6.14-rc2 — fixed in 6.1.129, 6.12.16, 6.13.4, 6.6.79
How to fix
Upgrade to a fixed version: Linux kernel 6.1.129, 6.12.16, 6.13.4, 6.6.79. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/022cac1c693add610ae76ede03adf4d9d5a2cf21
- https://git.kernel.org/stable/c/20a3489b396764cc9376e32a9172bee26a89dc3b
- https://git.kernel.org/stable/c/5bb4228c32261d06e4fbece37ec3828bcc005b6b
- https://git.kernel.org/stable/c/6ccaa5797f5362a2aad6baa6ddaf4715ac2dd51e
- https://git.kernel.org/stable/c/6d0ce46a93135d96b7fa075a94a88fe0da8e8773
- https://git.kernel.org/stable/c/7b81425b517accefd46bee854d94954f5c57e019
- https://git.kernel.org/stable/c/c40cb5c03e37552d6eff963187109e2c3f78ef6f
- https://git.kernel.org/stable/c/c7574740be8ce68a57d0aece24987b9be2114c3c
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://cert-portal.siemens.com/productcert/html/ssa-784472.html
Get alerted when CVE-2025-21791 or the next vulnerability affects your stack