What’s Vulnerable › Vulnerabilities
CVE-2025-21804: PCI: rcar-ep: Fix incorrect variable used when calling devm_request_mem_region()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-07-30
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: PCI: rcar-ep: Fix incorrect variable used when calling devm_request_mem_region() The rcar_pcie_parse_outbound_ranges() uses the devm_request_mem_region() macro to request a needed resource. A string variable that lives on the stack is then used to store a dynamically computed resource name, which is then passed on as one of the macro arguments. This can lead to undefined behavior. Depending on the current contents of the memory, the manifestations of errors may vary. One possible output may be as follows: $ cat /proc/iomem 30000000-37ffffff : 38000000-3fffffff : Sometimes, garbage may appear after the colon. In very rare cases, if no NULL-terminator is found in memory, the system might crash because the string iterator will overrun which can lead to access of unmapped memory above the stack. Thus, fix this by replacing outbound_name with the name of the previously requested resource. With the changes applied, the output will be as follows: $ cat /proc/iomem 30000000-37ffffff : memory2 38000000-3fffffff : memory3 [kwilczynski: commit log]
Affected products
- Linux kernel: from 5.8 before 5.10.235; from 5.11 before 5.15.179; from 5.16 before 6.1.129; from 6.2 before 6.6.76; from 6.7 before 6.12.13; from 6.13 before 6.13.2 — fixed in 5.10.235, 5.15.179, 6.1.129, 6.12.13, 6.13.2, 6.6.76
How to fix
Upgrade to a fixed version: Linux kernel 5.10.235, 5.15.179, 6.1.129, 6.12.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/24576899c49509c0d533bcf569139f691d8f7af7
- https://git.kernel.org/stable/c/2c54b9fca1755e80a343ccfde0652dc5ea4744b2
- https://git.kernel.org/stable/c/2d2da5a4c1b4509f6f7e5a8db015cd420144beb4
- https://git.kernel.org/stable/c/44708208c2a4b828a57a2abe7799c9d3962e7eaa
- https://git.kernel.org/stable/c/6987e021b64cbb49981d140bb72d9d1466f191c4
- https://git.kernel.org/stable/c/7a47e14c5fb0b6dba7073be7b0119fb8fe864e01
- https://git.kernel.org/stable/c/9ff46b0bfeb6e0724a4ace015aa7a0b887cdb7c1
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
Get alerted when CVE-2025-21804 or the next vulnerability affects your stack