What’s Vulnerable › Vulnerabilities
CVE-2025-21915: cdx: Fix possible UAF error in driver_override_show()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-07-30
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: cdx: Fix possible UAF error in driver_override_show() Fixed a possible UAF problem in driver_override_show() in drivers/cdx/cdx.c This function driver_override_show() is part of DEVICE_ATTR_RW, which includes both driver_override_show() and driver_override_store(). These functions can be executed concurrently in sysfs. The driver_override_store() function uses driver_set_override() to update the driver_override value, and driver_set_override() internally locks the device (device_lock(dev)). If driver_override_show() reads cdx_dev->driver_override without locking, it could potentially access a freed pointer if driver_override_store() frees the string concurrently. This could lead to printing a kernel address, which is a security risk since DEVICE_ATTR can be read by all users. Additionally, a similar pattern is used in drivers/amba/bus.c, as well as many other bus drivers, where device_lock() is taken in the show function, and it has been working without issues. This potential bug was detected by our experimental static analysis tool, which analyzes locking APIs and paired functions to identify data races and atomicity violations.
Affected products
- Linux kernel: from 6.4 before 6.6.83; from 6.7 before 6.12.19; from 6.13 before 6.13.7; 6.14-rc1, 6.14-rc2, 6.14-rc3, 6.14-rc4, 6.14-rc5 — fixed in 6.12.19, 6.13.7, 6.6.83
How to fix
Upgrade to a fixed version: Linux kernel 6.12.19, 6.13.7, 6.6.83. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0439d541aa8d3444ad41c39e39eb71acb57acde3
- https://git.kernel.org/stable/c/8473135f89c0949436a22adb05b8cece2fb3da91
- https://git.kernel.org/stable/c/91d44c1afc61a2fec37a9c7a3485368309391e0b
- https://git.kernel.org/stable/c/d7b339bbc887bcfc1a5b620bfc70c6fbb8f733bf
Get alerted when CVE-2025-21915 or the next vulnerability affects your stack