What’s Vulnerable › Vulnerabilities
CVE-2025-21927: nvme-tcp: fix potential memory corruption in nvme_tcp_recv_pdu()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-10-30
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: nvme-tcp: fix potential memory corruption in nvme_tcp_recv_pdu() nvme_tcp_recv_pdu() doesn't check the validity of the header length. When header digests are enabled, a target might send a packet with an invalid header length (e.g. 255), causing nvme_tcp_verify_hdgst() to access memory outside the allocated area and cause memory corruptions by overwriting it with the calculated digest. Fix this by rejecting packets with an unexpected header length.
Affected products
- Linux kernel: from 5.0 before 6.12.19; from 6.13 before 6.13.7; 6.14-rc1, 6.14-rc2, 6.14-rc3, 6.14-rc4, 6.14-rc5 — fixed in 6.12.19, 6.13.7
- Linux: 5.0 — fixed in 6.14
How to fix
Upgrade to a fixed version: Linux kernel 6.12.19, 6.13.7; Linux 6.14. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/22b06c89aa6b2d1ecb8aea72edfb9d53af8d5126
- https://git.kernel.org/stable/c/3b54109b2f771f74fd53b027429796326f84ab36
- https://git.kernel.org/stable/c/9d22cf5cc94cd7dee84773ec41db78a46107dfa3
- https://git.kernel.org/stable/c/9fbc953d6b38bc824392e01850f0aeee3b348722
- https://git.kernel.org/stable/c/ad95bab0cd28ed77c2c0d0b6e76e03e031391064
Get alerted when CVE-2025-21927 or the next vulnerability affects your stack