What’s Vulnerable › Vulnerabilities
CVE-2025-21945: ksmbd: fix use-after-free in smb2_lock
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-07-30
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix use-after-free in smb2_lock If smb_lock->zero_len has value, ->llist of smb_lock is not delete and flock is old one. It will cause use-after-free on error handling routine.
Affected products
- Linux kernel: from 5.15 before 6.1.131; from 6.2 before 6.6.83; from 6.7 before 6.12.19; from 6.13 before 6.13.7; 6.14-rc1, 6.14-rc2, 6.14-rc3, 6.14-rc4, 6.14-rc5 — fixed in 6.1.131, 6.12.19, 6.13.7, 6.6.83
How to fix
Upgrade to a fixed version: Linux kernel 6.1.131, 6.12.19, 6.13.7, 6.6.83. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/410ce35a2ed6d0e114132bba29af49b69880c8c7
- https://git.kernel.org/stable/c/636e021646cf9b52ddfea7c809b018e91f2188cb
- https://git.kernel.org/stable/c/84d2d1641b71dec326e8736a749b7ee76a9599fc
- https://git.kernel.org/stable/c/8573571060ca466cbef2c6f03306b2cc7b883506
- https://git.kernel.org/stable/c/a0609097fd10d618aed4864038393dd75131289e
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-21945 or the next vulnerability affects your stack