What’s Vulnerable › Vulnerabilities
CVE-2025-21946: ksmbd: fix out-of-bounds in parse_sec_desc()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-07-30
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix out-of-bounds in parse_sec_desc() If osidoffset, gsidoffset and dacloffset could be greater than smb_ntsd struct size. If it is smaller, It could cause slab-out-of-bounds. And when validating sid, It need to check it included subauth array size.
Affected products
- Linux kernel: from 5.15 before 6.6.83; from 6.7 before 6.12.19; from 6.13 before 6.13.7; 6.14-rc1, 6.14-rc2, 6.14-rc3, 6.14-rc4, 6.14-rc5 — fixed in 6.12.19, 6.13.7, 6.6.83
How to fix
Upgrade to a fixed version: Linux kernel 6.12.19, 6.13.7, 6.6.83. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/159d059cbcb0e6d0e7a7b34af3862ba09a6b22d1
- https://git.kernel.org/stable/c/6a9831180d0b23b5c97e2bd841aefc8f82900172
- https://git.kernel.org/stable/c/c1569dbbe2d43041be9f3fef7ca08bec3b66ad1b
- https://git.kernel.org/stable/c/d6e13e19063db24f94b690159d0633aaf72a0f03
- https://git.kernel.org/stable/c/f4ee19528664777af8b842f8f001be98345aa973
Get alerted when CVE-2025-21946 or the next vulnerability affects your stack