What’s Vulnerable › Vulnerabilities
CVE-2025-21947: ksmbd: fix type confusion via race condition when using ipc_msg_send_request
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix type confusion via race condition when using ipc_msg_send_request req->handle is allocated using ksmbd_acquire_id(&ipc_ida), based on ida_alloc. req->handle from ksmbd_ipc_login_request and FSCTL_PIPE_TRANSCEIVE ioctl can be same and it could lead to type confusion between messages, resulting in access to unexpected parts of memory after an incorrect delivery. ksmbd check type of ipc response but missing add continue to check next ipc reponse.
Affected products
- Linux kernel: from 5.15 before 6.1.131; from 6.2 before 6.6.83; from 6.7 before 6.12.19; from 6.13 before 6.13.7; 6.14-rc1, 6.14-rc2, 6.14-rc3, 6.14-rc4, 6.14-rc5 — fixed in 6.1.131, 6.12.19, 6.13.7, 6.6.83
How to fix
Upgrade to a fixed version: Linux kernel 6.1.131, 6.12.19, 6.13.7, 6.6.83. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1e8833c03a38e1d5d5df6484e3f670a2fd38fb76
- https://git.kernel.org/stable/c/3cb2b2e41541fe6f9cc55ca22d4c0bd260498aea
- https://git.kernel.org/stable/c/6321bbda4244b93802d61cfe0887883aae322f4b
- https://git.kernel.org/stable/c/76861630b29e51373e73e7b00ad0d467b6941162
- https://git.kernel.org/stable/c/e2ff19f0b7a30e03516e6eb73b948e27a55bc9d2
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-21947 or the next vulnerability affects your stack