What’s Vulnerable › Vulnerabilities
CVE-2025-21964: cifs: Fix integer overflow while processing acregmax mount option
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: cifs: Fix integer overflow while processing acregmax mount option User-provided mount parameter acregmax of type u32 is intended to have an upper limit, but before it is validated, the value is converted from seconds to jiffies which can lead to an integer overflow. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: from 5.12 before 5.15.180; from 5.16 before 6.1.132; from 6.2 before 6.6.84; from 6.7 before 6.12.20; from 6.13 before 6.13.8; 6.14-rc1, 6.14-rc2, 6.14-rc3, 6.14-rc4, 6.14-rc5, 6.14-rc6 — fixed in 5.15.180, 6.1.132, 6.12.20, 6.13.8, 6.6.84
How to fix
Upgrade to a fixed version: Linux kernel 5.15.180, 6.1.132, 6.12.20, 6.13.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0252c33cc943e9e48ddfafaa6b1eb72adb68a099
- https://git.kernel.org/stable/c/5f500874ab9b3cc8c169c2ab49f00b838520b9c5
- https://git.kernel.org/stable/c/7489161b1852390b4413d57f2457cd40b34da6cc
- https://git.kernel.org/stable/c/833f2903eb8b70faca7967319e580e9ce69729fc
- https://git.kernel.org/stable/c/a13351624a6af8d91398860b8c9d4cf6c8e63de5
- https://git.kernel.org/stable/c/dd190168e60ac15408f074a1fe0ce36aff34027b
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-21964 or the next vulnerability affects your stack