What’s Vulnerable › Vulnerabilities
CVE-2025-21967: ksmbd: fix use-after-free in ksmbd_free_work_struct
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-10-30
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix use-after-free in ksmbd_free_work_struct ->interim_entry of ksmbd_work could be deleted after oplock is freed. We don't need to manage it with linked list. The interim request could be immediately sent whenever a oplock break wait is needed.
Affected products
- Linux kernel: from 5.15 before 6.6.84; from 6.7 before 6.12.20; from 6.13 before 6.13.8; 6.14-rc1, 6.14-rc2, 6.14-rc3, 6.14-rc4, 6.14-rc5, 6.14-rc6 — fixed in 6.6.84, 6.12.20, 6.13.8
- Linux: 5.15 — fixed in 6.14
How to fix
Upgrade to a fixed version: Linux kernel 6.6.84, 6.12.20, 6.13.8; Linux 6.14. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/62746ae3f5414244a96293e3b017be637b641280
- https://git.kernel.org/stable/c/bb39ed47065455604729404729d9116868638d31
- https://git.kernel.org/stable/c/eb51f6f59d19b92f6fe84d3873f958495ab32f0a
- https://git.kernel.org/stable/c/fb776765bfc21d5e4ed03bb3d4406c2b86ff1ac3
- https://git.kernel.org/stable/c/ffe0909010b21df8f948d624ad00cf14dd856721
Get alerted when CVE-2025-21967 or the next vulnerability affects your stack