What’s Vulnerable › Vulnerabilities
CVE-2025-21975: net/mlx5: handle errors in mlx5_chains_create_table()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-01 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: net/mlx5: handle errors in mlx5_chains_create_table() In mlx5_chains_create_table(), the return value of mlx5_get_fdb_sub_ns() and mlx5_get_flow_namespace() must be checked to prevent NULL pointer dereferences. If either function fails, the function should log error message with mlx5_core_warn() and return error pointer.
Affected products
- Linux kernel: from 5.6 before 5.10.236; from 5.11 before 5.15.180; from 5.16 before 6.1.132; from 6.2 before 6.6.84; from 6.7 before 6.12.20; from 6.13 before 6.13.8 — fixed in 5.10.236, 5.15.180, 6.1.132, 6.12.20, 6.13.8, 6.6.84
How to fix
Upgrade to a fixed version: Linux kernel 5.10.236, 5.15.180, 6.1.132, 6.12.20. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/093b4aaec97ec048623e3fe1e516fc45a954d412
- https://git.kernel.org/stable/c/1598307c914ba3d2642a2b03d1ff11efbdb7c6c2
- https://git.kernel.org/stable/c/15bdd93728369b2c8942a8e5d549d4b5dc04a2d9
- https://git.kernel.org/stable/c/1d34296409a519b4027750e3e82d9e19553a7398
- https://git.kernel.org/stable/c/29c419c64e9b396baeda1d8713d2aa3ba7c0acf6
- https://git.kernel.org/stable/c/637105ef0d46fe5beac15aceb431da3ec832bb00
- https://git.kernel.org/stable/c/eab0396353be1c778eba1c0b5180176f04dd21ce
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-21975 or the next vulnerability affects your stack