What’s Vulnerable › Vulnerabilities
CVE-2025-22001: accel/qaic: Fix integer overflow in qaic_validate_req()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-03 · updated 2026-07-30
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: accel/qaic: Fix integer overflow in qaic_validate_req() These are u64 variables that come from the user via qaic_attach_slice_bo_ioctl(). Use check_add_overflow() to ensure that the math doesn't have an integer wrapping bug.
Affected products
- Linux kernel: from 6.4 before 6.6.85; from 6.7 before 6.12.21; from 6.13 before 6.13.9; 6.14-rc1, 6.14-rc2, 6.14-rc3, 6.14-rc4, 6.14-rc5, 6.14-rc6 (+1) — fixed in 6.12.21, 6.13.9, 6.6.85
How to fix
Upgrade to a fixed version: Linux kernel 6.12.21, 6.13.9, 6.6.85. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4b2a170c25862ad116bd31be6b9841646b4862e8
- https://git.kernel.org/stable/c/57fae0c505f49bb1e3d5660cd2cc49697ed85f7c
- https://git.kernel.org/stable/c/67d15c7aa0864dfd82325c7e7e7d8548b5224c7b
- https://git.kernel.org/stable/c/b362fc904d264a88b4af20baae9e82491c285e9c
Get alerted when CVE-2025-22001 or the next vulnerability affects your stack