What’s Vulnerable › Vulnerabilities
CVE-2025-22008: regulator: check that dummy regulator has been probed before using it
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: regulator: check that dummy regulator has been probed before using it Due to asynchronous driver probing there is a chance that the dummy regulator hasn't already been probed when first accessing it.
Affected products
- Linux kernel: before 5.10.236; from 5.11 before 5.15.180; from 5.16 before 6.1.132; from 6.2 before 6.6.85; from 6.7 before 6.12.21; from 6.13 before 6.13.9 — fixed in 5.10.236, 5.15.180, 6.1.132, 6.12.21, 6.13.9, 6.6.85
How to fix
Upgrade to a fixed version: Linux kernel 5.10.236, 5.15.180, 6.1.132, 6.12.21. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/21e3fdf3146f9c63888d6bfabbd553434a5fb93f
- https://git.kernel.org/stable/c/2c7a50bec4958f1d1c84d19cde518d0e96a676fd
- https://git.kernel.org/stable/c/998b1aae22dca87da392ea35f089406cbef6032d
- https://git.kernel.org/stable/c/a99f1254b11eaadd0794b74a8178bad92ab01cae
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-22008 or the next vulnerability affects your stack