What’s Vulnerable › Vulnerabilities
CVE-2025-22042: ksmbd: add bounds check for create lease context
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-07-30
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: add bounds check for create lease context Add missing bounds check for create lease context.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.15 before 6.1.134; from 6.2 before 6.6.87; from 6.7 before 6.12.23; from 6.13 before 6.13.11; from 6.14 before 6.14.2 — fixed in 6.1.134, 6.12.23, 6.13.11, 6.14.2, 6.6.87
How to fix
Upgrade to a fixed version: Linux kernel 6.1.134, 6.12.23, 6.13.11, 6.14.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/60b7207893a8a06c78441934931a08fdad63f18e
- https://git.kernel.org/stable/c/629dd37acc336ad778979361c351e782053ea284
- https://git.kernel.org/stable/c/800c482c9ef5910f05e3a713943c67cc6c1d4939
- https://git.kernel.org/stable/c/9a1b6ea955e6c7b29939a6d98701202f9d9644ec
- https://git.kernel.org/stable/c/a41cd52f00907a040ca22c73d4805bb79b0d0972
- https://git.kernel.org/stable/c/bab703ed8472aa9d109c5f8c1863921533363dae
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-22042 or the next vulnerability affects your stack