What’s Vulnerable › Vulnerabilities
CVE-2025-2205: GDPR Cookie Compliance <= 4.15.6 - Authenticated (Admin+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The GDPR Cookie Compliance – Cookie Banner, Cookie Consent, Cookie Notice – CCPA, DSGVO, RGPD plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 4.15.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- GDPR Cookie Compliance: before 4.15.7 — fixed in 4.15.7
How to fix
Upgrade to a fixed version: GDPR Cookie Compliance 4.15.7. Check the vendor advisory for mitigations.
References
- https://research.cleantalk.org/cve-2025-1622/
- https://wpscan.com/vulnerability/7a903d61-2792-4fe0-a26b-f400f4a3124b/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/37da32e4-48a1-4830-a47c-c454d60c9811?source=cve
Get alerted when CVE-2025-2205 or the next vulnerability affects your stack