What’s Vulnerable › Vulnerabilities
CVE-2025-22071: spufs: fix a leak in spufs_create_context()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: spufs: fix a leak in spufs_create_context() Leak fixes back in 2008 missed one case - if we are trying to set affinity and spufs_mkdir() fails, we need to drop the reference to neighbor.
Affected products
- Linux kernel: from 2.6.25 before 5.4.292; from 5.5 before 5.10.236; from 5.11 before 5.15.180; from 5.16 before 6.1.134; from 6.2 before 6.6.87; from 6.7 before 6.12.23 — fixed in 5.10.236, 5.15.180, 5.4.292, 6.1.134, 6.12.23, 6.13.11
How to fix
Upgrade to a fixed version: Linux kernel 5.10.236, 5.15.180, 5.4.292, 6.1.134. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0f5cce3fc55b08ee4da3372baccf4bcd36a98396
- https://git.kernel.org/stable/c/239ea3c34673b3244a499fd65771c47e5bffcbb0
- https://git.kernel.org/stable/c/410c787d89c92df4215d7b1a338e2c1a8aba6b9b
- https://git.kernel.org/stable/c/4a7448c83e117ed68597952ecaede1cebc4427a7
- https://git.kernel.org/stable/c/5a90b699844a5bb96961e5892e51cc59255444a3
- https://git.kernel.org/stable/c/829bd6139968e2e759f3928cf65ad0db1e302fe3
- https://git.kernel.org/stable/c/a333f223e555d27609f8b45d75a08e8e1d36c432
- https://git.kernel.org/stable/c/c4e72a0d75442237b6f3bcca10a7d81b89376d16
- https://git.kernel.org/stable/c/d04600f43569d48262e1328eaa1592fcefa2c19c
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-22071 or the next vulnerability affects your stack