What’s Vulnerable › Vulnerabilities
CVE-2025-22080: fs/ntfs3: Prevent integer overflow in hdr_first_de()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-07-30
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: fs/ntfs3: Prevent integer overflow in hdr_first_de() The "de_off" and "used" variables come from the disk so they both need to check. The problem is that on 32bit systems if they're both greater than UINT_MAX - 16 then the check does work as intended because of an integer overflow.
Affected products
- Linux kernel: from 6.2 before 6.6.87; from 6.7 before 6.12.23; from 6.13 before 6.13.11; from 6.14 before 6.14.2 — fixed in 6.12.23, 6.13.11, 6.14.2, 6.6.87
How to fix
Upgrade to a fixed version: Linux kernel 6.12.23, 6.13.11, 6.14.2, 6.6.87. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/201a2bdda13b619c4927700ffe47d387a30ced50
- https://git.kernel.org/stable/c/6bb81b94f7a9cba6bde9a905cef52a65317a8b04
- https://git.kernel.org/stable/c/85615aa442830027923fc690390fa74d17b36ae1
- https://git.kernel.org/stable/c/b9982065b82b4177ba3a7a72ce18c84921f7494d
- https://git.kernel.org/stable/c/f6d44b1aa46d317e52c21fb9314cfb20dd69e7b0
Get alerted when CVE-2025-22080 or the next vulnerability affects your stack