What’s Vulnerable › Vulnerabilities
CVE-2025-22087: bpf: Fix array bounds error with may_goto
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-07-30
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: bpf: Fix array bounds error with may_goto may_goto uses an additional 8 bytes on the stack, which causes the interpreters[] array to go out of bounds when calculating index by stack_size. 1. If a BPF program is rewritten, re-evaluate the stack size. For non-JIT cases, reject loading directly. 2. For non-JIT cases, calculating interpreters[idx] may still cause out-of-bounds array access, and just warn about it. 3. For jit_requested cases, the execution of bpf_func also needs to be warned. So move the definition of function __bpf_prog_ret0_warn out of the macro definition CONFIG_BPF_JIT_ALWAYS_ON.
Affected products
- Linux kernel: from 6.9 before 6.12.23; from 6.13 before 6.13.11; from 6.14 before 6.14.2 — fixed in 6.12.23, 6.13.11, 6.14.2
How to fix
Upgrade to a fixed version: Linux kernel 6.12.23, 6.13.11, 6.14.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/19e6817f84000d0b06f09fd69ebd56217842c122
- https://git.kernel.org/stable/c/1a86ae57b2600e5749f5f674e9d4296ac00c69a8
- https://git.kernel.org/stable/c/4524b7febdd55fb99ae2e1f48db64019fa69e643
- https://git.kernel.org/stable/c/6ebc5030e0c5a698f1dd9a6684cddf6ccaed64a0
Get alerted when CVE-2025-22087 or the next vulnerability affects your stack