What’s Vulnerable › Vulnerabilities
CVE-2025-22088: RDMA/erdma: Prevent use-after-free in erdma_accept_newconn()
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-07-30
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: RDMA/erdma: Prevent use-after-free in erdma_accept_newconn() After the erdma_cep_put(new_cep) being called, new_cep will be freed, and the following dereference will cause a UAF problem. Fix this issue.
Affected products
- Linux kernel: from 6.0 before 6.1.134; from 6.2 before 6.6.87; from 6.7 before 6.12.23; from 6.13 before 6.13.11; from 6.14 before 6.14.2 — fixed in 6.1.134, 6.12.23, 6.13.11, 6.14.2, 6.6.87
How to fix
Upgrade to a fixed version: Linux kernel 6.1.134, 6.12.23, 6.13.11, 6.14.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/667a628ab67d359166799fad89b3c6909599558a
- https://git.kernel.org/stable/c/78411a133312ce7d8a3239c76a8fd85bca1cc10f
- https://git.kernel.org/stable/c/7aa6bb5276d9fec98deb05615a086eeb893854ad
- https://git.kernel.org/stable/c/83437689249e6a17b25e27712fbee292e42e7855
- https://git.kernel.org/stable/c/a114d25d584c14019d31dbf2163780c47415a187
- https://git.kernel.org/stable/c/bc1db4d8f1b0dc480d7d745a60a8cc94ce2badd4
- https://lists.debian.org/debian-lts-announce/2025/05/msg00045.html
Get alerted when CVE-2025-22088 or the next vulnerability affects your stack