What’s Vulnerable › Vulnerabilities
CVE-2025-22096: drm/msm/gem: Fix error code msm_parse_deps()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: drm/msm/gem: Fix error code msm_parse_deps() The SUBMIT_ERROR() macro turns the error code negative. This extra '-' operation turns it back to positive EINVAL again. The error code is passed to ERR_PTR() and since positive values are not an IS_ERR() it eventually will lead to an oops. Delete the '-'. Patchwork: https://patchwork.freedesktop.org/patch/637625/
Affected products
- Linux kernel: from 6.14 before 6.14.2 — fixed in 6.14.2
How to fix
Upgrade to a fixed version: Linux kernel 6.14.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0b305b7cadce835505bd93183a599acb1f800a05
- https://git.kernel.org/stable/c/efe759dcf3352d8379a1adad7b4d14044a4c41a7
Get alerted when CVE-2025-22096 or the next vulnerability affects your stack