What’s Vulnerable › Vulnerabilities
CVE-2025-22107: net: dsa: sja1105: fix kasan out-of-bounds warning in sja1105_table_delete_entry()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-10-15
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: fix kasan out-of-bounds warning in sja1105_table_delete_entry() There are actually 2 problems: - deleting the last element doesn't require the memmove of elements [i + 1, end) over it. Actually, element i+1 is out of bounds. - The memmove itself should move size - i - 1 elements, because the last element is out of bounds. The out-of-bounds element still remains out of bounds after being accessed, so the problem is only that we touch it, not that it becomes in active use. But I suppose it can lead to issues if the out-of-bounds element is part of an unmapped page.
Affected products
- Linux kernel: from 5.2 before 6.14.2 — fixed in 6.14.2
How to fix
Upgrade to a fixed version: Linux kernel 6.14.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/031e00249e9e6bee72ba66701c8f83b45fc4b8a2
- https://git.kernel.org/stable/c/4584486cfcca24b7b586da3377eb3cffd48669ec
- https://git.kernel.org/stable/c/59b97641de03c081f26b3a8876628c765b5faa25
- https://git.kernel.org/stable/c/5f2b28b79d2d1946ee36ad8b3dc0066f73c90481
- https://git.kernel.org/stable/c/b52153da1f42e2f4d6259257a7ba027331671a93
- https://git.kernel.org/stable/c/f117d0467215d7f1d445ae16d2c799637e63dc6c
- https://git.kernel.org/stable/c/f85b9bfb08ba2b642d1810c6c4ae1e7b46f1776a
- https://cert-portal.siemens.com/productcert/html/ssa-019113.html
- https://cert-portal.siemens.com/productcert/html/ssa-457936.html
Get alerted when CVE-2025-22107 or the next vulnerability affects your stack