What’s Vulnerable › Vulnerabilities
CVE-2025-22112: eth: bnxt: fix out-of-range access of vnic_info array
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-16 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: eth: bnxt: fix out-of-range access of vnic_info array The bnxt_queue_{start | stop}() access vnic_info as much as allocated, which indicates bp->nr_vnics. So, it should not reach bp->vnic_info[bp->nr_vnics].
Affected products
- Linux kernel: from 6.12.20 before 6.12.35; from 6.13.8 before 6.14; 6.14, 6.14-rc7, 6.14.1 — fixed in 6.12.35, 6.14
How to fix
Upgrade to a fixed version: Linux kernel 6.12.35, 6.14. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/919f9f497dbcee75d487400e8f9815b74a6a37df
- https://git.kernel.org/stable/c/b1e081d331ab3a0dea25425f2b6ddeb365fc9d22
- https://git.kernel.org/stable/c/e1724f07693439deaa413ebc2a2640325cf247f5
Get alerted when CVE-2025-22112 or the next vulnerability affects your stack